Video in Logger Pro

Video can be used in Logger Pro in a number of ways.

e You can analyze a video frame by frame to track the motion of one or more objects. This
is called video analysis and is most often used in physics.

e You can view a video that is synchronized to sensor data. This enhanced record of an
experiment can be replayed at varying speeds, and the graph Examine feature will snap
the video to the corresponding frame as the mouse is moved over a graph.

e Or, you can do both synchronized video with sensor data coupled with video analysis.
The videos you use can either be existing files, such as those supplied with Logger Pro, or you
can capture the videos yourself using a variety of cameras. Logger Pro includes video capture
features to make capture simple.

This introduction to video in Logger Pro first discusses video analysis, then the process of
viewing and synchronizing video to sensor data, and finally the process of video capture.

Video Analysis

You can use the Video Analysis tool to create a graphical representation of the motion you see in
a movie or picture’. This is ideal for mathematically analyzing real-world events.

After you insert a movie, you will be able to open the Video Analysis toolbar. The motion that
you trace directly on the movie will be displayed on a linked graph. After the desired range of
motion has been graphed, you can use Logger Pro's analysis features to study the plotted data.

Logger Pro can analyze any movie that can be played by Quicktime, which includes most movie
formats including .avi and .mov. These can be movies that you capture directly from a video
input such as a digital video camera or web camera.

! Instead of marking one object across frames (time) as you would in a movie, analysis of a picture allows you to
mark many points on one frame. This is useful in getting the points along a curve, for example.
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Movie Buttons: There are five buttons in the bottom left corner of the movie object (Fig. 1) The
button furthest on the left is the Play button. Click it to play the movie. The next button to the
right is the Stop button. It will stop the movie during replay. The third button "rewinds" the
video to the beginning. The next two buttons move the video to the previous or next frame.

Click in the bottom right corner of the movie object to open the Video Analysis Toolbar. A
new graph will also be displayed, and a new columns are added to the data table.
Video Analysis Toolbar Buttons

The Video Analysis Toolbar buttons run along the right edge of the video, and provide access to
all the video point-manipulation features in Logger Pro.

Select Point: Selects an

existing point on the movie.
Select this tool, click on a point, and
the point will be selected and the
video will jump to the corresponding
frame. The marked point can be
dragged to change the position of the
point, or it can be deleted.
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Eﬂ Add Point: Enters the
point marking mode to track
objects through the frames of the
video. Once in the Add Point mode,
click on the object you are following.
Logger Pro will draw a point on the
location, and then advance the frame

of the video.
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E Set Origin: Sets the
‘ location of the origin. Once in Set Origin mode, click on the video to set the origin. If
desired, drag the yellow dot to rotate the coordinate system. This is helpful, for example, when

A3 i

50 Video in Logger Pro



studying the motion of a cart rolling up or down an inclined ramp. For experiments like the one
in Figure 3 where the x-axis is not horizontal, it is convenient to rotate the coordinate system so
that the x-axis is parallel to the ramp.

@ Set Scale: When you add points to the movie, s =
the program initially records the coordinates of each _ .

point in screen pixels. This option allows you to convert SIS SR o s Do cotospon S e

those coordinates to a physical measurement such as o . TEE

meters. In the example shown above, the meter stick can be

used to set the scale. Click the Set Scale button and drag B | [ ok ] coed |

across the length of the meter stick. A dialog will open for
you to enter the length of the object you have indicated.

Set Active Point: You can follow the motion of multiple objects in the video. After
marking the position of one object, rewind the video to the first useful frame. Click the Set
Active Point button, and use the popup menu to create a new data series. A new series adds
columns to the data table, and points marked on the video will be added to the new series. You
can also choose to return to a previous series using this tool.

E Toggle Trail: Displays or hides all the points that have been added up to the current
time. For example, if you have a total of 10 points, one point per second, and you toggle at
5 seconds, you would see the points from 0-5 seconds.

L‘i’l ~Show Origin: Display the origin on the movie object. Click again to remove the
== origin. The origin is set with the Set Origin button.

E Show Scale: This will show or hide the line that was used when setting the scale (see
Set Scale).

A tutorial covering video analysis is available. Select Open from the File menu, and then open
Tutorial 12-Video Analysis in the Tutorials folder.

For a sample photo or image analysis project, open the file Sample Data\Mathematics\Catenary
Model\stlouisarch.cmbl. In this file a photo (not a multiple frame video) is analyzed to model the
shape of the St. Louis Arch.

Viewing videos synchronized with sensor data

Logger Pro includes a number of sample videos. Choose Open from the File menu, and navigate
to the Sample Movies folder. As an example, open the Ball Toss folder and open the file called
Ball Toss. Here are some things to try with this file:

e Click the Start button in the Replay control to both play the video and display the Motion
Detector data.

e After the replay ends, change the replay speed to 0.5, and click start again. Is it easier to
see what is happening?
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e Click the Examine button “;f and move the mouse over the velocity graph. Use this tool

to determine where the ball is when the velocity graph cross through zero. Note that the
video frame displayed corresponds to the cursor location when in Examine mode.

Synchronizing videos with sensor data

The videos described in the previous section have already been synchronized with the sensor
data. This section describes how to insert and then synchronize an existing video to some sensor
data.

If it is not already open, open the Ball Toss file in Sample Movies/Ball Toss. Click the start
button on the Replay control to play the video and expose the data. After replay completes, click
once on the video and delete it using the Delete key on the keyboard. Now you have some
motion detector data with no video, and you can practice the process of inserting an existing
video and then syncing it to the data.

1. Insert the video by choosing Movie from the Insert menu. Since you recently
opened the Ball Toss file, the open file dialog should still be pointing to the Ball
Toss folder (if not, navigate there). Select the Ball Toss.mov file (that’s the video
file) and click Open. If you like, choose Auto Arrange from the Page menu to
clean up the layout.

2. Click the Start button on the Replay control. Note that the video and data are no
longer synced; you’re about to fix that.

To synchronize a movie with data you need to identify a common moment in time in both the
data and movie. Sometimes you can use the physics of the motion, but in other cases you may
have an event such as a finger tapping a force sensor before an experiment actually starts to find
the common time. In this case we’ll use the physics of the event. The ball is farthest from the
motion detector when the ball is at the maximum height; the position graph shows a maximum
value. Those are the moments in time we want to synchronize.

3. Click the Sync button on the video object. This opens a dialog, which you
may want to drag out of the way. You’ll need to be able to see both the position
graph and the video.

4. Click on the graph at the maximum position value. This places a dot on the graph,
and enters the corresponding time from the data into the sync dialog box.

5. Use the play, forward and backward controls on video to move to the frame where
the ball is at its maximum height.

6. Click OK in the Movie Synchronization dialog to commit to the synchronization.

7. Click Start in the Replay tool, and note that your video is now synchronized to the
data.

A tutorial covering video synchronization is available. Select Open from the File menu, and then
open Tutorial 11-1 Working with Movies in the Tutorials folder.
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Video Capture

Logger Pro can capture video directly from a video input such as a digital video camera or web
camera. The video might be captured on its own, or it might be captured while sensor data are
also being collected. Time lapse videos are available, with or without sensor data.

Recommended Cameras

1. a consumer DV camera with firewire or USB 2 output
2. Logitech QuickCam Pro 5000 (Windows only)

3. Apple iSight

4. Proscope

If your intended video analysis use is in physics, with objects in freefall motion, you will almost
certainly want the higher quality provided by a DV camera. Webcams, the iSight and the
Proscope work will for slower events, time lapse, and for documenting experiments with still
images. Video capture may work with other USB or firewire cameras; however Logger Pro has
not been tested with them.

Many digital still cameras can collect short video clips that are ideal for use with Logger Pro.
However, since these cameras are not designed to be controlled by a computer, they cannot
capture video under the control of Logger Pro. Instead, the video must be collected using the
camera’s controls and transferred from the camera as a file. Then the processes above of using an
existing video file can be used.

The following steps for video captures assume that any software that comes with the camera has
already been installed on the computer. If the camera doesn’t work with the manufacturer’s
software, it cannot work with Logger Pro.

Video Capture Only
1. Connect the camera to the computer.

2. Start Logger Pro.

3. Choose Video Capture from the Insert menu. If a camera is detected, the Video Capture
dialog box will appear, and it will display an active video feed from the camera. If you do
not see the live video feed, click the set up camera button and configure your camera.

4. The Video Capture dialog box will show live video. Click the Options button in the
Video Capture dialog box to choose the Video Capture Only mode. Set your desired
capture duration. Note: Long captures that are not time-lapse will create very large files.

5. To capture video, click the Start Capture button. You can let the capture run for the
allotted time or click the Stop Capture button.

6. At the end of the capture, a movie object for the capture will appear on the Logger Pro
main window. If you capture additional videos, they will also appear on the Logger Pro
main window.

7. To save the movie or movies, choose Save from the File menu. Choose the appropriate
folder and give your Logger Pro file a name. The movie(s) will be saved in the same
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directory as your Logger Pro. By default the video files will be named sequentially,
MovieCapturel, MovieCapture2, etc.

Video Capture While Simultaneously Collecting Data

1. Set up some sensor for data collection.

2. Choose Video Capture from the Insert menu. Click the Options button to open the Video
Capture Options dialog.

2. Choose the Video Capture Synchronized with Sensor Data Collection option.

3. If data collection will run more than 10-15 seconds, you may want to capture a time-
lapse movie to avoid creating a very large video file. To enable this mode, click the Time
Lapse Mode option, and choose how often an image should be collected.

4. Click[ ok |

5. When you click the Start Capture or Start Time Lapse button, video capture and data
collection will start. Don’t use the standard Collect button, for it will not start the video
capture.

6. At the end of the capture, a movie object for the capture will appear on the Logger Pro
main window.

8. To save the movie or movies with your data, choose Save from the File menu. Choose the
appropriate folder and give your Logger Pro file a name. The movie(s) will be saved in
the same directory as your Logger Pro. By default the video files will be named
sequentially, MovieCapturel, MovieCapture2, etc.

Take Photo

You can use your video camera to take a snapshot, treated as a picture in JPEG format, by
clicking the Take Photo button. This feature is useful for documenting experimental setups.
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